View Single Post
  #4  
Old 07-03-2014
sagar bolisetti's Avatar
sagar bolisetti sagar bolisetti is offline
Flexsim User
 
Join Date: Aug 2013
Location: Hyderabad,India
Posts: 160
Downloads: 145
Uploads: 0
Thanks: 124
Thanked 99 Times in 63 Posts
Rep Power: 151
sagar bolisetti is a jewel in the roughsagar bolisetti is a jewel in the roughsagar bolisetti is a jewel in the roughsagar bolisetti is a jewel in the rough
Default

Hello Pongjetanapong

It seems you have directly copied the code from any one of the object triggers in the model.Triggers that have a return a value need to have a return value.Example process time field return a process time and setup field returns a setup time.But user command is not like that you have to specify your own parameters that can be passed into a user command.The return value and parameter list are just used by the Flexscript parser to give you warnings if you are not defined them.In you case you have some special characters that was not defined i.e / and about "." i didnt see this character in your window may be that was the problem Jorg defined.If you are not using the special character in your script window than dont write it.

For any reasons if you want to use special characters ex: concatenate you can use the escape character '\' to prefix a quotation mark (and other special characters) and therefore adds it your string

string str="/\.";

assigns the two characters /. to the string str.

Edit:

Okay.The above description is only used in the context of flexscript.To conform I have just read in the manual that Flexscript parser does not read the text line part of the code.I dont know why this happens in your case.May be you have copied from different source and i hope jorg suggestion should work for you.

Last edited by sagar bolisetti; 07-04-2014 at 11:53 AM.
Reply With Quote
The Following 2 Users Say Thank You to sagar bolisetti For This Useful Post:
Jörg Vogel (07-03-2014), Pongjetanapong (07-06-2014)