FlexSim Community Forum

FlexSim Community Forum (https://archive.flexsim.com/index.php)
-   Gripes and Goodies (https://archive.flexsim.com/forumdisplay.php?f=115)
-   -   Decelartion of TE on network (https://archive.flexsim.com/showthread.php?t=3034)

Paul Wiedeking 04-28-2015 06:48 PM

Decelartion of TE on network
 
1 Attachment(s)
Hi everybody

currently, I build a very simple model consisting of a TE (elevator)
traveling on a two node network up and down. The elevator picks up
a flowitem at the ground level and drops it in the upper level. I specified
the acceleration and deceleration property of the elevator but only the
acceleration has a visible effect on its speed. The elevator arrives with full
speed at the levels and stops immediatly without decelerating. Why?

Does it need manual adaption of the tasksequences to use decelartion?

A attached my example model (FlexSim 7.5).

Thanks in advance
Paul

Jörg Vogel 04-28-2015 07:06 PM

Hello Paul,

as I understand the deceleration parameter is used when an Taskexecuter travels on a network and the edge he travels on has got a speed limit smaller then his current speed. A deceleration you see too when the taskexecuter is in Offset traveling.
Jörg

Paul Wiedeking 04-29-2015 01:25 AM

Hi Joerg

thanks for your reply.
Ok, obviously I had a wrong imagination of how the decelaration property
is applied. Nevertheless, I want my elevator to decelerate when arriving at
its destination network node. Currently, I can only think of some sophisticated
manual calculations of the point where the elevator has to start decelerating and
insert a new network node right at this point and decreas all speedlimits between
the newly inserted node and the destination node accordingly...

But this approach seems too complicated to me.
Any suggestions how to solve this problem more elegantly?

Paul

Steven Hamoen 04-29-2015 02:35 AM

Have you looked at Kinematics? That gives you precise control over what ever movement you need.

Jason Lightfoot 04-29-2015 03:21 AM

Correct acceleration/deceleration is the elevator's default behavior without network nodes.

It would be nice if disabling offset travel on networks also gave the correct speeds.

Jason Lightfoot 04-29-2015 04:29 AM

1 Attachment(s)
If you use traveltoloc, you'd be forcing offset travel for the whole movement, which will use the acceleration/deceleration. Example of that attached creates ts on the source reads the network node locations, and assumes the you're dispatching directly to the elevator.

Paul Wiedeking 04-29-2015 09:13 AM

Hi Jason

thank you very much for your solution.
Works perfectly and solves my problem.

Maybe deceleration for non-offset travel is a feature for
future releases?

Paul

Phil BoBo 04-29-2015 09:16 AM

2 Attachment(s)
The default task sequence uses the task executer's max speed as the end speed for the 2 travel tasks in the task sequence.

If you use the "Task Sequence Example_1" pick option in the Use Transport field and change var1 on the travel tasks to -1, then it will use zero as the end speed of the travel task and will decelerate to 0 at the end of the travel task.

Attached is your model modified accordingly.

https://www.flexsim.com/community/fo...1&d=1430320585

Paul Wiedeking 04-29-2015 07:02 PM

Hi Phil

that's exactly what I was looking for.
Thank you very much for your hint.

Cheers
Paul


All times are GMT -6. The time now is 10:57 PM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
Copyright 1993-2018 FlexSim Software Products, Inc.